Language

Package: wxwidgets-gtk2 @ 3.0.5.1

Synopsis

Widget toolkit for creating graphical user interfaces

Description

wxWidgets is a C++ library that lets developers create applications with a graphical user interface. It has language bindings for Python, Perl, Ruby and many other languages.

Home page
https://www.wxwidgets.org/
Location
gnu/packages/wxwidgets.scm (line: 156, column: 2)
Licenses

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/9xnlmf2z1yrnc7v3gb163d7ix8lp392r-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/kq0ykr5bv858zgj8xq6gdkc7caffh831-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/g7ffr9j55bqpvm83xy6riav9lsyacw76-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/rrvxzrh5s9vwika3daax03h5q67k7zmw-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxi686-w64-mingw32/gnu/store/pngm569i2hvivkfacl4dwnvdavwwzv71-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxi586-pc-gnu/gnu/store/awbgfvfv4773p6422qnw46n5j8p0rdyf-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/zl9mmaf2xwvqhbyj4anzarkjx814p6p4-wxwidgets-gtk2-3.0.5.1.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/84rcm8jqjp5qpcb5h5sc0cmsjm1wgj2n-wxwidgets-gtk2-3.0.5.1.drv
riscv64-linux/gnu/store/xghmhwlqlwhlnix3ndm18w9gwcxypd4k-wxwidgets-gtk2-3.0.5.1.drv
    powerpc-linux/gnu/store/2w1vfy25pzal6vd2r3pwx87jbxrl65aj-wxwidgets-gtk2-3.0.5.1.drv
      powerpc64le-linux/gnu/store/1b87z4y05lb8mfslklzmpjv5vp0gwry7-wxwidgets-gtk2-3.0.5.1.drv
      mips64el-linux/gnu/store/lwry1cinwhc9w8rmgnapd3qryfc18pwj-wxwidgets-gtk2-3.0.5.1.drv
        i686-linux/gnu/store/s8zw8fl4dskkwnaliaqmn4c92zwrxk0d-wxwidgets-gtk2-3.0.5.1.drv
        armhf-linux/gnu/store/2p0w8p2qkgksrlqb5hql14r7qmmfx5dm-wxwidgets-gtk2-3.0.5.1.drv
        aarch64-linux/gnu/store/l0aaj7schigfd8wzfjb6vrjwy6h1xhzk-wxwidgets-gtk2-3.0.5.1.drv

        Lint warnings

        LinterMessageLocation
        description

        Validate package descriptions

        description should start with an upper-case letter or digit
        input-labels

        Identify input labels that do not match package names

        label 'gtk' does not match package name 'gtk+'
        input-labels

        Identify input labels that do not match package names

        label 'libjpeg' does not match package name 'libjpeg-turbo'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>