Language

Package: gcc-cross-sans-libc-arm-none-eabi @ 7-2018-q2-update-1.261907

Synopsis

GNU Compiler Collection

Description

GCC is the GNU Compiler Collection. It provides compiler front-ends for several languages, including C, C++, Objective-C, Fortran, Ada, and Go. It also includes runtime support libraries for these languages.

Home page
https://gcc.gnu.org/
Location
gnu/packages/embedded.scm (line: 287, column: 4)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/rqvh4in0125n3xi4xc69kyzh5qnfqzw5-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/lxnsqf1fd0hc1ki36snc3f36y0s649q7-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/gj57hxyyvip67fyz3r7ygw7gsqaffdw0-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/ydwpi31mjbmnmf1lx3azfcj64r04vz81-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/biqn213jm7mywch7cbcz537fjh7v7xb3-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/jrhzn8bwaly3yh8677ywrrg9a7cgkw6d-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxi686-w64-mingw32/gnu/store/prjj1yd3lr10j1sfcqh3j56ycr032xb5-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxi586-pc-gnu/gnu/store/wphplpzcsdllm40vv211k3ng4dp4k203-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/5hr2vggca2hc3cm0nw88jv9ra21qgg13-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/yw6kpzb4ip8b2j7y602kq2cbv2ggwilx-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
riscv64-linux/gnu/store/2m1md9jmf2v5rzarjyl6hwscaj7q209m-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
    powerpc-linux/gnu/store/pmvlibbnji61hskd8ldfl5linj9c65cc-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
      powerpc64le-linux/gnu/store/hi5psbba0i3rksc91i6g10lcgwglnamx-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
      mips64el-linux/gnu/store/lyfrhskgrld61cz9bfxs77zxrbrsqvcv-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
        i686-linux/gnu/store/5axqvpbsvvl3bd7kj3h2m7bn11pvz57f-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
        i586-gnu/gnu/store/mfzncf9vq5ryh8nhh0za852w854pm10y-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
        armhf-linux/gnu/store/7438f2rydbplxj0gasniaqngxgq5l7wx-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv
        aarch64-linux/gnu/store/yr7yfd97qqyz299dwdx63lgrkblkv2v2-gcc-cross-sans-libc-arm-none-eabi-7-2018-q2-update-1.261907.drv

        Lint warnings

        LinterMessageLocation
        patch-file-names

        Validate file names and availability of patches

        file names of patches should start with the package name
        formatting

        Look for formatting issues in the source

        line 345 is way too long (99 characters)
        input-labels

        Identify input labels that do not match package names

        label 'ld-wrapper-cross' does not match package name 'ld-wrapper-arm-none-eabi'
        input-labels

        Identify input labels that do not match package names

        label 'binutils-cross' does not match package name 'binutils-cross-arm-none-eabi'
        input-labels

        Identify input labels that do not match package names

        label 'libstdc++' does not match package name 'libstdc++-headers'
        input-labels

        Identify input labels that do not match package names

        label 'bash' does not match package name 'bash-minimal'
        input-labels

        Identify input labels that do not match package names

        label 'locales' does not match package name 'glibc-utf8-locales'
        input-labels

        Identify input labels that do not match package names

        label 'libc-native' does not match package name 'glibc'
        input-labels

        Identify input labels that do not match package names

        label 'libc-native:static' does not match package name 'glibc:static'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>