Language

Package: xtensor-benchmark @ 0.24.0

Synopsis

Benchmarks of the xtensor library

Description

xtensor is a C++ library meant for numerical analysis with multi-dimensional array expressions.

xtensor provides:

  • an extensible expression system enabling lazy broadcasting.

  • an API following the idioms of the C++ standard library.

  • tools to manipulate array expressions and build upon xtensor.

Home page
https://xtensor.readthedocs.io/en/latest/
Location
gnu/packages/algebra.scm (line: 1168, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/8bqslscvcv7c3krhv9s5gijd0c63f6mn-xtensor-benchmark-0.24.0.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/m8fy1fkxbmzj81d4aqg3pbv7wflm2ykq-xtensor-benchmark-0.24.0.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/dzs33h36blhmicr61v0926qrwjhw1x0p-xtensor-benchmark-0.24.0.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/jjv6bsl70ifb4vhqmrjw30y5sgaa7sw9-xtensor-benchmark-0.24.0.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/d6w0c7amvmidzf9b1bkchrhv5zk1zyfs-xtensor-benchmark-0.24.0.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/fi42hnc3lh96awyr1y3fhv830ihskp61-xtensor-benchmark-0.24.0.drv
x86_64-linuxi686-w64-mingw32/gnu/store/q6p63h3d33ncrzl8mx3813pasqrw1xdz-xtensor-benchmark-0.24.0.drv
x86_64-linuxi586-pc-gnu/gnu/store/0nrlynswrmwm7rl4i30vj29gd45v0903-xtensor-benchmark-0.24.0.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/dry9md40kpbws3w5zm4x838s3dg8zw6g-xtensor-benchmark-0.24.0.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/idplwphlw332wp7vsc1mp8la04vp14kk-xtensor-benchmark-0.24.0.drv
riscv64-linux/gnu/store/17fv4n73ghjzdxgpcp04l9cl0h4qjm0b-xtensor-benchmark-0.24.0.drv
    powerpc-linux/gnu/store/59y6y76x8dyjq9d77s7iispx7ynjixgr-xtensor-benchmark-0.24.0.drv
      powerpc64le-linux/gnu/store/vhz3di3a47cybyp8jgkqqyjb1bfw527f-xtensor-benchmark-0.24.0.drv
      mips64el-linux/gnu/store/9c06mkds4g2lrdqyvqfjdcm0iqk7qv9p-xtensor-benchmark-0.24.0.drv
        i686-linux/gnu/store/6qg1gqdjw4knb5gwgq8zpn3xfha7ikxb-xtensor-benchmark-0.24.0.drv
        i586-gnu/gnu/store/41y90sp1x2dikma7x7pmg9vv4wrm5zys-xtensor-benchmark-0.24.0.drv
        armhf-linux/gnu/store/l3dgnhkr8q87wmr2sqz4dgl69bypvgkb-xtensor-benchmark-0.24.0.drv
        aarch64-linux/gnu/store/9zznimvp9agph8br8a1n7jdl4slmgf3z-xtensor-benchmark-0.24.0.drv

        Lint warnings

        LinterMessageLocation
        description

        Validate package descriptions

        description should start with an upper-case letter or digit
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>