Language

Package: squirrel @ 3.1

Synopsis

High level imperative, object-oriented programming language

Description

Squirrel is a high level imperative, object-oriented programming language, designed to be a light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games.

Home page
https://squirrel-lang.org/
Location
gnu/packages/squirrel.scm (line: 31, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/nw2fda0n51x0kv8g06mv95iskn0kyiww-squirrel-3.1.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/5bsfiqcaxbjrr5qzx7airxnn1ypqaifj-squirrel-3.1.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/1xni9s9j2ws4zvg04zgs55dac7m9wdlm-squirrel-3.1.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/df5mcbk9w9lpikyx8rjp1v9l2lc80dir-squirrel-3.1.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/vxj4l08znjihxwzrkg3gfk599vxl0fyb-squirrel-3.1.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/aqi1bsh82lhw8kgwidchcara0kq4xqw9-squirrel-3.1.drv
x86_64-linuxi686-w64-mingw32/gnu/store/lircsbwk7sxq9znginj64y6z2havyg85-squirrel-3.1.drv
x86_64-linuxi586-pc-gnu/gnu/store/iiqs48mig8kcnsinpi0419ydnl2pbdrl-squirrel-3.1.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/6m8j7ah86vcn5fxvadv6442pj2bl2cl5-squirrel-3.1.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/1lgyn7a3mj4njcf0z1zi68rb243adra8-squirrel-3.1.drv
riscv64-linux/gnu/store/4w9pnqhih6i41r9kg3p1y767npqvf46x-squirrel-3.1.drv
    powerpc-linux/gnu/store/gsysxxkr3ljni267n5cynbdd9qk6i380-squirrel-3.1.drv
      powerpc64le-linux/gnu/store/a804i6mi5zz0qsa2gfagx62nmpy62fsn-squirrel-3.1.drv
      mips64el-linux/gnu/store/58y010z4jwvq89w6fgwsj6n40hxi2qvc-squirrel-3.1.drv
        i686-linux/gnu/store/7xg4bxsy5mf2zgy7wvya2l70ddba878c-squirrel-3.1.drv
        i586-gnu/gnu/store/psgr25p5cpnxiwjyp9bxl2alv1zg7w2g-squirrel-3.1.drv
        armhf-linux/gnu/store/5l3wi33jk5xmgx2fhv9dfy492csfvvcy-squirrel-3.1.drv
        aarch64-linux/gnu/store/gq7al037nvdinica5jghwri52wiwh63w-squirrel-3.1.drv

        Lint warnings

        LinterMessageLocation
        input-labels

        Identify input labels that do not match package names

        label 'cmake' does not match package name 'cmake-minimal'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>