Language

Package: guile2.2-git @ 0.5.2

Synopsis

Guile bindings for libgit2

Description

This package provides Guile bindings to libgit2, a library to manipulate repositories of the Git version control system.

Home page
https://gitlab.com/guile-git/guile-git.git
Location
guix/packages.scm (line: 1440, column: 15)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/7b7qyw0ygrzazm5sh0b968i3m062h525-guile2.2-git-0.5.2.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/wybbj95crmzsl245vq4aq0y4dhvgvf28-guile2.2-git-0.5.2.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/0ihq9jk6bwmimdhlg572dipyayl0bdb6-guile2.2-git-0.5.2.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/xhdkl64yb44qrpzzxm2anz98jp2iklda-guile2.2-git-0.5.2.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/4g6cxs1wz9q8a6gl0r7yl60ijivsijvd-guile2.2-git-0.5.2.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/vk0ygn633fgrld724zp7asqv46vbq1p2-guile2.2-git-0.5.2.drv
x86_64-linuxi686-w64-mingw32/gnu/store/y5lb5mvjk7gv8xf2vfnrd9gxbxfs6mcv-guile2.2-git-0.5.2.drv
x86_64-linuxi586-pc-gnu/gnu/store/fyv6zym966v8gjs3gs5rygm9j85q20kw-guile2.2-git-0.5.2.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/fzgq7hp2p6a5f0dlq6lq55rixdbfhw66-guile2.2-git-0.5.2.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/d9zlhqg4qy2sy60qhbliwfjrb788nl7r-guile2.2-git-0.5.2.drv
riscv64-linux/gnu/store/rwbp2zd4q4rb1j6dpwvr90pxfzxmdb66-guile2.2-git-0.5.2.drv
    powerpc-linux/gnu/store/b8x6blqj5a6sz33rywgn6y4c4y7mhzzi-guile2.2-git-0.5.2.drv
      powerpc64le-linux/gnu/store/y4l4k9xpp8wji3xy6sw2ffwxzbw8rykv-guile2.2-git-0.5.2.drv
      mips64el-linux/gnu/store/s2d27p1sn63jjynb5zbqwzvvpvkjg2yz-guile2.2-git-0.5.2.drv
        i686-linux/gnu/store/ddcck0339nyshyb55xp8hz40nslamazp-guile2.2-git-0.5.2.drv
        i586-gnu/gnu/store/zcwad2xcbrg7h0szj2s7xd2jnlh6x7p1-guile2.2-git-0.5.2.drv
        armhf-linux/gnu/store/g5j4201wjnq5265bvi59lskjjqjn1k73-guile2.2-git-0.5.2.drv
        aarch64-linux/gnu/store/fgjidwcdlg7an6vl1x93b2cfr775rijf-guile2.2-git-0.5.2.drv

        Lint warnings

        LinterMessageLocation
        patch-file-names

        Validate file names and availability of patches

        file names of patches should start with the package name
        patch-headers

        Validate patch headers

        guile-git-adjust-for-libgit2-1.2.0.patch: patch lacks comment and upstream status
        input-labels

        Identify input labels that do not match package names

        label 'guile-bytestructures' does not match package name 'guile2.2-bytestructures'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>