Language

Package: guile2.0-git @ 0.5.2

Synopsis

Guile bindings for libgit2

Description

This package provides Guile bindings to libgit2, a library to manipulate repositories of the Git version control system.

Home page
https://gitlab.com/guile-git/guile-git.git
Location
guix/packages.scm (line: 1440, column: 15)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/a2s1z1p1r5f1qgjc275gr8z7qmilz8rv-guile2.0-git-0.5.2.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/fz4h40szw4ng5sm7ks9zvqdkldygyxki-guile2.0-git-0.5.2.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/3j3zg3238jq8wdq7siiarh9ivnppiaa3-guile2.0-git-0.5.2.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/6fws65ygn1ibm2wq1zbxjrlpvdfi4b08-guile2.0-git-0.5.2.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/fxxinmqkfgr1hp0rv7ikx51dw12m4555-guile2.0-git-0.5.2.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/1n4d0qmwp0cbbh0jsjyxjjp5d9bvw66k-guile2.0-git-0.5.2.drv
x86_64-linuxi686-w64-mingw32/gnu/store/y1l1wqqzmqdcmafdyq3shq5h7gzpq4cx-guile2.0-git-0.5.2.drv
x86_64-linuxi586-pc-gnu/gnu/store/lb8xwf5x6wyc0snxj2qksfy5a5qipk7a-guile2.0-git-0.5.2.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/2cvakhcdz2pc3mh57r1mdp55v54amjjx-guile2.0-git-0.5.2.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/y7mrvwsqc2ffgqj5jq075rwp3xsn9nlh-guile2.0-git-0.5.2.drv
riscv64-linux/gnu/store/8nlw0bgg2swchbgbsxx8li3m6pz6qb59-guile2.0-git-0.5.2.drv
    powerpc-linux/gnu/store/sk9ydjd5yvhhsw3wqhgxxhn9d3xgdv6m-guile2.0-git-0.5.2.drv
      powerpc64le-linux/gnu/store/mfpzpbpwxilvbx29p4qqfpw4p7nsw7q8-guile2.0-git-0.5.2.drv
      mips64el-linux/gnu/store/73pmrvrv9yv95mrnjynwl8pinasqxvvc-guile2.0-git-0.5.2.drv
        i686-linux/gnu/store/7x07gflqcnxz7zkwwjcyvqzk9g2a3pg5-guile2.0-git-0.5.2.drv
        i586-gnu/gnu/store/zjl5iqqx9liz6k4nj509p2xgk8gzxyad-guile2.0-git-0.5.2.drv
        armhf-linux/gnu/store/y6akl260aj82lbwsh4jgdmjrml5n9jcr-guile2.0-git-0.5.2.drv
        aarch64-linux/gnu/store/j8b3z3ifbq48z80glyvzxac0rqs64fk4-guile2.0-git-0.5.2.drv

        Lint warnings

        LinterMessageLocation
        patch-file-names

        Validate file names and availability of patches

        file names of patches should start with the package name
        patch-headers

        Validate patch headers

        guile-git-adjust-for-libgit2-1.2.0.patch: patch lacks comment and upstream status
        input-labels

        Identify input labels that do not match package names

        label 'guile-bytestructures' does not match package name 'guile2.0-bytestructures'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>