Language

Package: libxcrypt @ 4.4.28

Synopsis

Extended crypt library for descrypt, md5crypt, bcrypt, and others

Description

libxcrypt is a modern library for one-way hashing of passwords. It supports a wide variety of both modern and historical hashing methods: yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt, md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.

Home page
https://github.com/besser82/libxcrypt
Location
gnu/packages/crypto.scm (line: 1670, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/cv3jpgsv9h30acg9xyb445q2qi1c2v1z-libxcrypt-4.4.28.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/nz6xilqby8bbgc7gxbvd8m57r0pymqik-libxcrypt-4.4.28.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/154gz7xfw0g0lbbbnklnxngc0sbdh6iw-libxcrypt-4.4.28.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/p7l1cy5z0x9x67xi85h03y8frc5nd3r4-libxcrypt-4.4.28.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/phf1kipz04g9wm12b2xyh28078ng9lwn-libxcrypt-4.4.28.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/s65rkjrlx65b1qx6204bz4h2krd1r508-libxcrypt-4.4.28.drv
x86_64-linuxi686-w64-mingw32/gnu/store/7x13q439yaiw5q3gqvgbpp8nmyr9xn0m-libxcrypt-4.4.28.drv
x86_64-linuxi586-pc-gnu/gnu/store/8xkijdxagpj8c1dr2x6cz0g7kk3abdfv-libxcrypt-4.4.28.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/skm6r5ym61ry6sk4mpkdxkq6m18sjscx-libxcrypt-4.4.28.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/vs9pgxggkfx9i15hyljnsqpyvmfkfv9m-libxcrypt-4.4.28.drv
riscv64-linux/gnu/store/rdmdkb23q1r9inl5ygdj2iqps5xlw71j-libxcrypt-4.4.28.drv
    powerpc-linux/gnu/store/irdivsnhbg8pc32c695f1g8q99w6q8py-libxcrypt-4.4.28.drv
      powerpc64le-linux/gnu/store/w88idds9k0cnwmpadwjlrhnci1b0mq39-libxcrypt-4.4.28.drv
      mips64el-linux/gnu/store/nqjb9qc503sclzz1dascss99m845qnk2-libxcrypt-4.4.28.drv
        i686-linux/gnu/store/947agk1gidcizac32zpx87aqdgf1xykl-libxcrypt-4.4.28.drv
        i586-gnu/gnu/store/f7i9plam35myncw5fwcdfhhpgqrigp8q-libxcrypt-4.4.28.drv
        armhf-linux/gnu/store/4342hwr3vdv1q1hq58839j7wnkpg74fx-libxcrypt-4.4.28.drv
        aarch64-linux/gnu/store/mmbq9n275hd67n8nmlllxsr96nq0m8qk-libxcrypt-4.4.28.drv

        Lint warnings

        LinterMessageLocation
        description

        Validate package descriptions

        sentences in description should be followed by two spaces; possible infraction at 62
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>