Language

Package: java-ops4j-pax-tinybundles @ 2.1.1

Synopsis

Java APIs to create OSGi related artifacts

Description

Tinybundles is all about creating OSGi related artifacts like Bundles, Fragments and Deployment Packages with Java Api. It is very convenient to create such artifacts on-the-fly inside Tests (like in Pax Exam). On the other hand, this library can be a foundation of real end user tools that need to create those artifacts.

Home page
https://ops4j1.jira.com/wiki/spaces/ops4j/pages/12060312/Tinybundles
Location
gnu/packages/java.scm (line: 9876, column: 2)
License

Lint warnings

LinterMessageLocation
source-unstable-tarball

Check for autogenerated tarballs

the source URI should not be an autogenerated tarball
input-labels

Identify input labels that do not match package names

label 'junit' does not match package name 'java-junit'
input-labels

Identify input labels that do not match package names

label 'hamcrest' does not match package name 'java-hamcrest-core'
input-labels

Identify input labels that do not match package names

label 'log4j' does not match package name 'java-log4j-api'
input-labels

Identify input labels that do not match package names

label 'bndannotation' does not match package name 'java-aqute-bnd-annotation'
input-labels

Identify input labels that do not match package names

label 'framework' does not match package name 'java-osgi-framework'
input-labels

Identify input labels that do not match package names

label 'lang' does not match package name 'java-ops4j-base-lang'
input-labels

Identify input labels that do not match package names

label 'io' does not match package name 'java-ops4j-base-io'
input-labels

Identify input labels that do not match package names

label 'store' does not match package name 'java-ops4j-base-store'
input-labels

Identify input labels that do not match package names

label 'slf4j' does not match package name 'java-slf4j-api'
input-labels

Identify input labels that do not match package names

label 'libg' does not match package name 'java-aqute-libg'
input-labels

Identify input labels that do not match package names

label 'bndlib' does not match package name 'java-aqute-bndlib'
derivation

Report failure to compile a package to a derivation

failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
derivation

Report failure to compile a package to a derivation

failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
derivation

Report failure to compile a package to a derivation

failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
derivation

Report failure to compile a package to a derivation

failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>