Language

Package: guile2.0-git @ 0.5.2

Synopsis

Guile bindings for libgit2

Description

This package provides Guile bindings to libgit2, a library to manipulate repositories of the Git version control system.

Home page
https://gitlab.com/guile-git/guile-git.git
Location
guix/packages.scm (line: 1440, column: 15)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/scw5c4frsxhphqfmvsy6q1dwn7aivix6-guile2.0-git-0.5.2.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/xbrm5zm3f7y2wfggmwddwdk23g7iaa3y-guile2.0-git-0.5.2.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/7xbin79mhl1y81xxpaca3bw5kpzvw43w-guile2.0-git-0.5.2.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/vv7apiis98q7m89ybrzlwwicxk8j78g9-guile2.0-git-0.5.2.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/8zf0xvscfbbnz0w7jlkp3d1cjs1awqil-guile2.0-git-0.5.2.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/7ilr76x7xy2al25wdvlpjjb3dwz0630b-guile2.0-git-0.5.2.drv
x86_64-linuxi686-w64-mingw32/gnu/store/1p2zhbif2r3nh0g7yjlygwgc6lj3x0by-guile2.0-git-0.5.2.drv
x86_64-linuxi586-pc-gnu/gnu/store/qdc6ylrbyfgagh1m0l14dniy244p83dm-guile2.0-git-0.5.2.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/pvm0yz6y299dlksinjcjk1vs6zjmq3c4-guile2.0-git-0.5.2.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/k2m2aahsqb4xq8j1ngq89r6lvlmq9aj0-guile2.0-git-0.5.2.drv
riscv64-linux/gnu/store/kyjwcwhgryykg9kbpwjl59mwlm2ydj6q-guile2.0-git-0.5.2.drv
    powerpc-linux/gnu/store/7fil5ck25jrc2v1xcn8bc0l7d2yzinj7-guile2.0-git-0.5.2.drv
      powerpc64le-linux/gnu/store/n2r2rbwlird3jbqrvabqxyw61pl1mzwy-guile2.0-git-0.5.2.drv
      mips64el-linux/gnu/store/v8kxpnj685dxja8x8jamswxjc4aah5gv-guile2.0-git-0.5.2.drv
        i686-linux/gnu/store/jm1xdb061jlbxvrv1yhbn85dbbfg2r78-guile2.0-git-0.5.2.drv
        i586-gnu/gnu/store/d2dwl0mg83ngp6k1m8482dfvylm2iba2-guile2.0-git-0.5.2.drv
        armhf-linux/gnu/store/in3f88qf17h43mxlzgqgw44w63f2cv3g-guile2.0-git-0.5.2.drv
        aarch64-linux/gnu/store/5cgmqi5sablc4f5j1jafkmiin6vccvs1-guile2.0-git-0.5.2.drv

        Lint warnings

        LinterMessageLocation
        patch-file-names

        Validate file names and availability of patches

        file names of patches should start with the package name
        patch-headers

        Validate patch headers

        guile-git-adjust-for-libgit2-1.2.0.patch: patch lacks comment and upstream status
        input-labels

        Identify input labels that do not match package names

        label 'guile-bytestructures' does not match package name 'guile2.0-bytestructures'
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f8ed7409c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7fa7aa068c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f5755cb9c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7487 7f119da52c60> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fb2d2987dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f3e6bc77dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f62abeb7dc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7fa23c1dddc0> input: ("_" "static")>
        derivation

        Report failure to compile a package to a derivation

        failed to create i586-gnu derivation: #<&package-input-error package: #<package nghttp2@1.48.0 gnu/packages/web.scm:7492 7f0f10522dc0> input: ("_" "static")>